Back to overview
Resolved

Short Network Outage Maribor - Slovenia

Sep 7, 2026 at 10:35pm UTC
Affected services
T-2 Datacenter - Maribor
MB-11 Ryzen 9000 Node

Resolved
Sep 7, 2026 at 10:35pm UTC

Our upstream provider T-2 in Maribor is currently performing network maintenance, which may temporarily impact connectivity and service availability.

Update: The situation appears to be recovering, and services are gradually returning to normal.

We are continuing to monitor the maintenance and will provide further updates as necessary.