Back to overview
Resolved

Upstream Maintenance – T-2, Maribor

Sep 7, 2026 at 10:05pm UTC  –  Sep 8, 2026 at 4:00am UTC
Affected services
T-2 Datacenter - Maribor
MB-11 Ryzen 9000 Node

Resolved
Sep 8, 2026 at 4:00am UTC

Maintenance ended

Created
Sep 7, 2026 at 10:05pm UTC

Our upstream provider T-2 in Maribor will be performing scheduled network maintenance.

During this maintenance window, customers may experience temporary connectivity interruptions or degraded service.

We will monitor the maintenance closely and provide updates once the work has been completed and services are fully restored.

Thank you for your understanding.