Back to overview
Resolved

Amsterdam Downtime

Jul 5, 2026 at 9:38am UTC
Affected services
Digital Realty AMS5 - Amsterdam

Resolved
Jul 6, 2026 at 11:42am UTC

We have replaced the defective hardware components in Amsterdam, and all services have been fully restored as of approximately 30 minutes ago. We will continue to monitor the situation to ensure stability.

We apologize for the inconvenience and thank you for your patience.

Updated
Jul 5, 2026 at 11:30am UTC

We have identified a hardware defect as the cause of the downtime in Amsterdam. The affected hardware will be inspected tomorrow as early in the day as possible. We will share more information here as soon as it becomes available.

Created
Jul 5, 2026 at 9:38am UTC

We are currently experience downtime in Amsterdam. We are investigating the issue