Back to overview
Resolved

DDoS Attack in Maribor

Jul 30, 2026 at 11:27am UTC
Affected services
T-2 Datacenter - Maribor
MB-11 Ryzen 9000 Node

Resolved
Jul 30, 2026 at 11:27am UTC

Earlier today we experienced a DDoS attack targeting our network, which caused intermittent latency and packet loss for some services. Our team mitigated the attack and normal service has been fully restored. We apologize for any disruption.